Fix GAOSP Public Beta 3 “Can’t mount INTERNAL” error

by on May.04, 2011, under Stuff

I just tried to install a fresh GAOSP Public Beta 3 (Android 2.2 Froyo) on my Samsung Galaxy i7500 and came across this error:

Finding update package…
Opening update package…
Verifying update package…
Installing update…
Formating SYSTEM…
Copying files…
Copying files…

E:Can't mount /dev/block/mmcblk0p1 (no such device)
E:Can't mount INTERNAL:
E:Failure at line 328:
copy_dir PACKAGE:dev_data INTERNAL:
Sync data…
.Installation failed

After that my old ROM was broken and the installation process failed again and again.

Solution:

This error can by solved by fixing the permissions. You can simply do that using your recovery system. Boot again into recovery (press Volume Down + Start Call + End Call) and select Fix packages permissions.

See:
fix packages permissions
(close to the bottom)

Incoming search terms:

Share
:, , , ,

Leave a Reply

Looking for something?

Use the form below to search the site:

Still not finding what you're looking for? Drop a comment on a post or contact us so we can take care of it!